Help

Справка (инструкция) по DriverPack Solution

Материал из Справка по программе DriverPack Solution

(Перенаправлено с Main Page)
Перейти к: навигация, поиск

DriverPack Solution 10 – наиболее распространенная программа для автоматической установки драйверов. Новая, популярная, актуальная, стабильная, надежная, быстрая.

Программа заметно упрощает процесс переустановки Windows. Поиск и установка драйверов осуществляются в программе в несколько кликов. Все задачи, связанные с поиском и установкой драйверов, выполняются автоматически.

Содержание

  • 1 Немного о справке
  • 2 DriverPack Solution 10
    • 2.1 Преимущества
    • 2.2 Что нового в DriverPack Solution 10
    • 2.3 Получение информации о программе
      • 2.3.1 На официальном сайте www.drp.su
      • 2.3.2 На форуме forum.drp.su
      • 2.3.3 Техническая поддержка
  • 3 Работа с программой
    • 3.1 Основные элементы интерфейса
    • 3.2 Горячие клавиши
    • 3.3 Настройки
  • 4 Установка драйверов
    • 4.1 Интеллектуальный режим
    • 4.2 Ручной режим
    • 4.3 Установка через Интернет
    • 4.4 Установка с помощью кнопки «Установить (…)»
    • 4.5 Обновление драйверов до более свежих версий
  • 5 Принципы определения драйверов
    • 5.1 По уникальному номеру устройства
    • 5.2 Контроль версий драйверов
  • 6 Архивы драйверов
    • 6.1 Структура
    • 6.2 Где скачать
    • 6.3 Процесс создания индексов
    • 6.4 Структура индексных файлов
  • 7 Обновления
    • 7.1 Обновления программы
    • 7.2 Обновления драйверов
  • 8 Сервис DevID.drp.su
    • 8.1 Основные функции
    • 8.2 Интеграция с DriverPack Solution
  • 9 Температура процессора
  • 10 Устранение проблем
    • 10.1 Создание отчёта об ошибках
    • 10.2 Отправка отчёта разработчикам
  • 11 Использование стороннего кода
    • 11.1 Модуль 7za
    • 11.2 Модуль dpinst
    • 11.3 Модуль devcon
    • 11.4 Модуль mshta
  • 12 Лицензия
  • 13 Разработчики
  • 14 Некоторые полезные ресурсы

[править] Немного о справке

Справочная информация о программе поможет научиться пользоваться DriverPack Solution 10, понять ее преимущества и особенности работы. Вы можете использовать информацию для совершенствования работы своего компьютера. Программой может пользоваться как профессиональный пользователь, так и начинающий, во всех случая работа DriverPack Solution 10 будет эффективной и безотказной.

Справка построена по системе Wiki. Это значит, что каждый может вносить изменения/дополнения в справочный материал (руководствуясь здравым смыслом)!

[править] DriverPack Solution 10

DriverPack Solution 10 представляет собой эффективный и производительный менеджер установки драйверов для Windows XP, Windows Vista и Windows 7. Поиск и установка драйверов производится автоматически. Это значительно упрощает и ускоряет работу с системой.

Удобный пользовательский интерфейс, надежность и простоту в работе оценили уже более миллиона пользователей по всему миру. Известность DriverPack Solution 10, рост популярности программы – это всего лишь вопрос времени. Наличие большого количества положительных отзывов о программе – показатель правильности «выбранного пути».

Программу используют:

  • домашние компьютерные пользователи
  • системные администраторы
  • компьютерные мастера
  • сервис-центры по ремонту компьютеров
  • и другие люди, которые часто сталкиваются с установкой/переустановкой Windows

Плюсы в использовании программы

  • интерфейс, дружелюбный и интуитивно понятный
  • интеллектуальная технология классификации драйверов
  • несколько режимов установки (для профессионала, для начинающего пользователя)
  • многоязычность (не требует лингвистических познаний и усилий): Английский, Русский, Украинский, Немецкий, Французский, Итальянский, Испанский, Турецкий, Азербайджанский, Голландский, Литовский
  • проверка доступности новых версий программы (возможность быстрого и бесплатного обновления)

Функциональные возможности DriverPack Solution 10

  • эффективный и быстрый поиск драйверов
  • установка драйверов на практически любой компьютер, всего за несколько минут
  • проведение «даунгрейда» с Windows Vista на Windows XP (даже если производитель не разместил на своем сайте драйвера под Windows XP)
  • поиск и загрузка недостающего драйвера из Интернета, по заданным параметрам применения драйвера
  • быстрое обновление существующего набора установленных драйверов до более актуальных версий
  • помощь в создании и использовании собственных баз драйверов

Из дополнительных особенностей можно выделить поддержку программой абсолютно всех типов устройств (PCI/USB/ACPI/PNP и прочих). Это является весомым плюсом в графу «универсальность».

DriverPack Solution 10 распространяется абсолютно бесплатно (свободная лицензия GNU GPL). Открытый код программы позволит самостоятельно дорабатывать DriverPack Solution 10, тем самым совершенствуя ее, настраивая под конкретные потребности своей системы.

[править] Преимущества

Преимущества программы условно можно скомпоновать в группы, наиболее актуальные для пользователей.

  1. Доступность.
    • Программа является свободной.
    • Более того, в отличие от других «бесплатных» или условно бесплатных программ, ее можно скачать (заказать на дисках), без дополнительных действий: ввода ключей, кодов, паролей. Установленная полная версия программы работает корректно и не требует от пользователя дополнительных (зачастую весьма утомительных) действий по, например, активации этой версии программы.
  2. Установка.
    • Просто, быстро, безопасно.
    • Установленная программа не повлияет негативно на работу других приложений и системы в целом. Возможность выбора режимов (пакетов) установки позволяет работать с ней пользователям различных уровней подготовки.
  3. Использование.
    • Экономия времени на самостоятельном поиске и установке (переустановке) драйверов.
    • Уверенность пользователя в корректной работе системы, с новыми драйверами.
  4. Обновления.
    • Возможность автоматического поиска и установки новых версий драйверов и полезных утилит.
  5. Результат.
    • Экономия времени, сил, денег и прочих ресурсов.
    • Эффективная работа компьютера, системы, отсутствие проблем при установке нового оборудования, повышение производительности работы уже установленного оборудования.

Более подробно с преимуществами и с самой программой Вы можете ознакомиться на сайте http://drp.su/about.htm

[править] Что нового в DriverPack Solution 10

И без того удачная программа дополнилась нововведениями. Это повлияло, прежде всего, на следующие важнейшие критерии работы любого ПО.

  1. Производительность.
    • Поиск и установка драйверов происходит намного быстрее, эффективнее аналогов.
    • Поиск производится автоматически, не отрывая Вас от решения текущих задач.
  2. Интерфейс.
    • Стал более разветвленным, одновременно - более понятным, дружелюбным, удобным.
  3. Универсальность.
    • Пользоваться могут как обычные так и «продвинутые» пользователи.
    • Более того, пользователь, который не считает себя профессионалом, со временем научится мастерски выполнять все задачи, связанные с оптимизацией работы драйверов его системы.
  4. Мобильность.
    • Программа наряду с «зашитым» в нее алгоритмом поиска и обновления, предлагает массу дополнительных возможностей для работы с ней: самостоятельно настраивать и искать именно те драйвера, которые требуются конкретной системе.
  5. Безопасность.
    • Благодаря входящему сканированию, проверке драйверов на встроенные вредоносные программы, разработчики гарантируют корректную работу программы DriverPack Solution 10, ее совместимость с системой, а также поиск драйверов, которые абсолютно безопасны для работы вашего компьютера.

[править] Получение информации о программе

[править] На официальном сайте www.drp.su

Полный обзор программы, характеристики, особенности работы, требования к системе. Сайт предназначен как для организации доступа к программе, так и для поддержки пользователей: новых и уже использующих DriverPack Solution 10.

[править] На форуме forum.drp.su

Содержится более подробная информация о нюансах использования DriverPack Solution 10, о способах повышения ее производительности.

  • Для удобства посетителей наиболее часто задаваемые вопросы, выделены в отдельные темы.
  • Ведущие форума, специалисты, модераторы готовы ответить на все возникшие вопросы, развернуто, внятно, профессионально.

Комментарии пользователей также принесут определенную пользу всем желающим разобраться в тонкостях работы DriverPack Solution 10.

[править] Техническая поддержка

Оперативная помощь при возникших проблемах: как при установке, так и при работе с программой.

  • Программная поддержка пользователей, ответы (быстрые и точные) на вопросы, возникшие в момент работы программы, помощь в устранении ошибок, предупреждения пользователей о возможных внештатных ситуациях, которые могут возникнуть при некорректном использовании программы.

В отличие от форума, где ответы на вопросы хоть и исчерпывающие – могут «запаздывать», служба технической поддержки всегда поможет Вам решить возникшую проблему, оперативно ответит на ваши вопросы.

[править] Работа с программой

Работа с программой DriverPack Solution 10. Разработчики прекрасно справились с задачей: программа работает быстро, надежно, сбалансировано. В ней легко разобраться, ее можно дорабатывать под специфические потребности конкретной системы. При возникновении вопросов – служба технической поддержки оперативно поможет их решить.

[править] Основные элементы интерфейса

Разработка интерфейса DriverPack Solution 10 основывается на сочетании простоты и эффективности. Эффективность заключается в достижении большего результата за меньшее количество кликов. Простота заключатся в том, что программа не содержит запутанных меню, не требует сложных действий, одновременно выполняя (автоматически) большой объем работ по поиску и установке драйверов. Эргономика интерфейса построена на разделении рабочего пространства на 2 зоны: основную и вспомогательную.

В основной зоне отображаются: текущая информация о системе (1), устройствах (4), драйверах (3) и рекомендованные действия (2).

Во вспомогательной зоне расположены центры настроек и дополнительные сервисы (языковой, справочный и техподдержка).

Кнопка «Диспетчер устройств» служит для вывода системного диспетчера устройств. Позволяет получить список подключенных к компьютеру устройств.

«Обновление окна» - актуально после установки драйверов или других действий (выдается актуальная информация).

Пункт «Выбрать все» позволяет выделять все драйверы, в раскрытых ранее категориях.

Особое внимание пользователь обязательно обратит на развитую систему всплывающих подсказок. Это особенно актуально на этапе знакомства с программой и в начале работы с ней.

Простота и универсальность интерфейса не только повышают скорость работы с программой, но и делают эту работу мене утомительной.

Образец работы - эмулятор интерфейса Вы увидеть на сайте www.drp.su

[править] Горячие клавиши

Дополнительным плюсом для эргономики и скорости работы являются «горячие клавиши».

  • [D] - Диспетчер устройств
    Вызывает окно Диспетчера устройств операционной системы Windows.
    Используется для обновления драйверов оборудования, позволяет изменять настройки оборудования, а также служит для устранения неполадок. Возможность одним взглядом оценить «размер мороки».
  • [S] - Информация о системе
    Утилита MsInfo. Вызывает окно Сведения об установленной операционной системе.
    Для отображения данных о конфигурации системы.
  • [R] - Обновить окно
    Обновляет окно с информацией об имеющихся в системе устройствах, установленных драйверах, о пакетах драйверов.
  • [A] - Выбрать все (all)
    Служит для выбора/отмены выделения всех «драйверпаков» из списка.
  • [I] – Выполнить (install)
    Запускает процесс выполнения указанных пользователем действий: инсталлирование (установка) драйверов, индексация драйверпаков, прочие действия.
  • [P] – Температура процессора (processor)
    Обновить информацию о температуре процессора
  • [F1] - Справка
    Вызов справочной системы по DriverPack Solution 10.

[править] Настройки

Позволяют «подогнать» работу программы под конкретные требования пользователя или системы. Именно здесь реализуется возможность «усложнять» работу программы при повышении опыта работы с ней.

На начальном этапе – многие функции выполняются автоматически. Опытный же пользователь задает критерии работы программы самостоятельно, тем самым повышая эффективность ее работы. Именно для этого и создан «Режим Эксперта».

«Режим эксперта» реализует возможности расширенного управления программой: осуществляется настройка и конфигурирование работы программы. Также в этом режиме предоставляется возможность расширенного взаимодействия с пакетами драйверов.

В этом режиме реализуются следующие настройки:

Режимы работы

  • «Установка драйверов»

Расширенный режим установки, переустановки и обновления драйверов.

  • «Индексация драйверпаков»

Используется для добавления (индексации) в базу новых пакетов драйверов (драйверпаков).

Параметры (опции)

  • «Тихая установка»

Очень полезная опция. Позволяет скрывать «дополнительные» вопросы, которые задаются программой в ходе установки, а также не выводить окно результатов установки. То есть позволяет избежать появления поводов для «необязательного кликанья».

  • «Принудительная установка»

Пример адаптации программы под конкретные потребности пользователя. При включении этой опции, DriverPack Solution также будет устанавливать устаревшие драйвера. В случае если установленные в системе драйвера имеют более позднюю дату создания, нежели устанавливаемые драйвера, программа всё равно выполнит установку. То есть программа устанавливает именно то, что сейчас требуется пользователю.

  • Температура CPU

Информация о состоянии процессора.

  • «Хранить логи в текущей папке»

По умолчанию DriverPack Solution 10 хранит логи в папке своей же "logs", однако если программа запущенна с диска, то прямая запись в эту папку невозможна. Тогда логи ведутся в temp-папке. В случае запуска программы с флешки: со временем размер, занимаемый программой, будет увеличиваться (при каждом запуске программы ведутся логи), чтобы это отключить достаточно «снять» галочку "Хранить логи в текущей папке", логи будут в temp-папке, на флешке будет больше свободного места.

  • «Установить удобную старт. страницу»

Позволяет установить в браузере удобную домашнюю страницу, на которой интегрированы возможности поиска с использованием известных поисковых систем.

Начинающий пользователь, разобравшись в настройках и опциях программы, очень скоро перейдет в разряд эксперта и будет способен конфигурировать работу программы, настраивать ее под свою систему и манеру работы, улучшать производительность и отдачу DriverPack Solution 10.

[править] Установка драйверов

Установка драйверов, основная задача программы. Драйвера могут устанавливаться как из базы (архивы), так и при поиске их в Интернете.

Режим работы «Установка драйверов» предназначен для установки, переустановки и обновления драйверов. DriverPack Solution 10 автоматически распознает подключенное к ПК оборудование, устанавливает соответствие между найденными устройствами и имеющимися в базе драйверами.

Режим «Установка драйверов» используются программой по умолчанию, поэтому при запуске программы Вы можете наблюдать, что включен данный режим. Для того, чтобы начать установку, необходимо выбрать из списка те драйвера, которые подлежат установке. Для выбора драйвера требуется отметить его, поставив «галочку». Можно выбрать одновременно несколько драйверов, указав их в списке. Для выбора всех драйверов - кнопка «Выбрать все».

Существует несколько способов (режимов) установки драйверов с помощью DriverPack Solution 10, и вы можете использовать любой из них:

  • Интеллектуальная установка
  • Ручная установка
  • Поиск в Интернете
  • Кнопка "Установить (...)"

Для переключения имеющихся режимов установки необходимо предварительно отметить пункт «Режим эксперта», поставив в нём галочку (можно просто щёлкнуть мышью по кнопке «Режим эксперта»). После этого ниже кнопки «Режим эксперта» раскроется список дополнительных опций и установок.

[править] Интеллектуальный режим

Это наиболее простой для пользователя метод. Основан на «интеллекте» самой программы. DriverPack Solution 10 автоматически распознает оборудование, устанавливает соответствие между найденными устройствами и имеющимися драйверами. Процесс установки драйверов осуществляется программой автоматически.

Для начала установки требуется «кликнуть» левой клавишей мыши на кнопку «Интеллектуальная установка (рекомендуется)» в отображаемом списке «Драйвера требующие установки», в строке необходимого драйвера. Программа автоматически установит указанный драйвер, после чего будут обновлены списки драйверов.

[править] Ручной режим

Ручная установка предназначена для опытных пользователей, и требует навыков работы c «Мастером нового оборудования» (утилита Windows). Также как и в режиме «Интеллектуальной установки» все действия по распознаванию оборудования и подбору соответствующих драйверов DriverPack Solution 10 осуществляет автоматически. Процесс установки данным методом осуществляется пользователем самостоятельно.

Для использования данного метода, необходимо кликнуть левой клавишей мыши на кнопку «Ручная установка» в списке «Драйвера требующие установки», в строке необходимого драйвера, после чего откроется Окно Установки.

В появившемся окне «Установка драйверов» необходимо выполнить последовательность из следующих действий:

  1. Нажать на кнопку «Разархивировать», DriverPack Solution 10 автоматически распаковывает найденный драйвер во временную директорию.
  2. Нажать на клавиши CTRL-C, программа выдаст сообщение о том, что путь к распакованным файлам скопирован в буфер обмена. Кнопка «Обзор» позволяет открыть директорию, в которую были распакованы файлы драйвера.
  3. Нажать на кнопку «Установить», в случае успешной установки программа выдаст соответствующее сообщение. Выбранный драйвер будет установлен.
    В том случае, если не удалось осуществить установку указанным способом, можно использовать альтернативный вариант установки (изложенный в пунктах 4,5):
    …Выполнить действия, описанные в пунктах 1 и 2.
  4. Нажать на кнопку, после чего откроется Windows-окно «Мастер нового оборудования».
  5. Следуя инструкциям Мастера Нового Оборудования, установите драйвер, указав путь места поиска, ранее скопированный в буфер обмена (пункт 2).

Альтернативой может служить метод установки драйверов через «Диспетчер Устройств» в Windows. Утилита используется для проверки состояния оборудования и обновления драйверов на компьютере. Для запуска: «Пуск» >> «Панель управления» >> «Система» >> «Оборудование» >> «Диспетчер устройств».

Для установки драйвера (вручную) для устройства, зайдите в «Диспетчер устройств», нажмите правой кнопкой на «неизвестном» устройстве, и выберите пункт меню «Обновить драйвер». Будет запущен «Мастер Обновления Оборудования».

На его «предложение» загрузить ПО из Интернет, выбираем пункт «Нет, не в этот раз».

Далее требуется снять галочку «Поиск на сменных носителях», для того, чтобы не тратить время на бесполезный поиск. Далее – отметить пункт «Включите следующее место поиска», скопировать адрес папки, содержащей драйвера для данного устройства, и нажать «Далее».

После установки нажать «Готово». Драйвер установится. Можно проверять в «Диспетчере Устройств»: установился ли требуемый драйвер.

[править] Установка через Интернет

Метод «Поиск в Интернете» позволяет искать необходимые драйвера в Интернете.

Нажмите на кнопку «Поиск в Интернете», после чего программа перенаправит Вас на портал поиска DriverPack Solution 10, автоматически подставляя необходимые данные в строку поиска.

Поиск осуществляется на основании информации об устройстве (DevID). DevID (Device ID, ИД устройства) – уникальный идентификатор, однозначно характеризующий каждое устройство. Примечание: для использования данного метода необходимо подключение к сети Интернет.

[править] Установка с помощью кнопки «Установить (…)»

Этот метод схож с методом «Интеллектуальная установка», поскольку все действия по опознаванию оборудования и подбору соответствующих драйверов осуществляются программой автоматически.

Однако существуют некоторые функциональные особенности использования данного метода. Для использования данного метода первым шагом осуществляется выбор из списка драйверов подлежащих установке. Для выбора драйвера достаточно поставить напротив него галочку, Вы также можете выбрать одновременно несколько драйверов, указав их в списке. Для выбора всех драйверов из списка служит кнопка «Выбрать все».

Далее требуется нажать на кнопку «Установить (…)», где в скобках отображается общее число драйверов выбранных из списка. После чего программа автоматически запустит процесс установки. В списке драйверов Вы можете наблюдать за ходом процесса выполнения установки. В случае неудачи в процессе установки какого-либо из драйверов DriverPack Solution 10 выдаст соответствующие предупреждения.

[править] Обновление драйверов до более свежих версий

Более свежие версии драйверов содержатся в имеющихся архивах (драйверпаках). Для замены существующих драйверов на новые (более производительные) – достаточно нажать кнопку «Обновить все», все устаревшие драйвера будут заменены новыми.

Если требуется «апгрейд» драйверов по отдельности (по желанию пользователя), то это производится выбором одного или нескольких драйверов из предлагаемого к обновлению списка, и обновить (установить новые драйверы, в ручном или интеллектуальном режимах).

Преимущества работы более «свежих» версий драйверов – неоспоримы. Они повышают производительность, надежность работы устройства и системы в целом. При их разработке учтен немалая статистика и результаты работы предыдущих версий драйверов и устранено большинство причины возможных сбоев.

[править] Принципы определения драйверов

Основной принцип (важный именно для пользователя) – это то, что DriverPack Solution 10 определяет и отслеживает актуальность драйверов автоматически. При загрузке программы производится тестирование системы, определение текущих (установленных) драйверов, их сравнение (по дате выхода, по версии) с драйверами из драйверпаков в программе.

[править] По уникальному номеру устройства

Для каждого устройства в системе есть свой уникальный номер (DevID). Он отображается как в установках Windows, так и в программе DriverPack Solution 10. Уникальный для каждого устройства идентификатор (однозначно характеризующий каждое устройство) используется программой для автоматического «подбора» драйвера к нему.

База данных в программе содержит ID всех устройств, самостоятельно отслеживает версии драйверов для них, сопоставляет их версии, актуальность. В случае наличия в базе более новой версии, предлагает установить для устройства новый драйвер. Можно найти драйвер для конкретного устройства самостоятельно в Интернете, выбрав соответствующий режим поиска драйвера.

Примечание: для эффективной работы программы необходимы архивы драйверов (в формате 7z), а для быстрого поиска по ним, требуется проиндексировать файлы.

[править] Контроль версий драйверов

Выполняется программой. Результаты отображаются и в рабочем окне, и при подводе курсора к устройству (в виде всплывающей подсказки).

Удобно. Не требуется самостоятельно осуществлять проверку актуальности, программа это делает автоматически, предлагая обновить устаревшие драйвера или, разумеется, отказаться от обновления. Это позволяет пользователю не тратить время на поиск обновлений, их анализ.

[править] Архивы драйверов

Кроме уже содержащихся (довольно обширных) в программе архивов драйверов, DriverPack Solution 10 предоставляет возможность создания пользовательских драйверпаков. Это актуально как при наличии нестандартного оборудования, так и к «привязанности» операционной системы пользователя к некоторым типам (возможно устаревших) драйверов.

[править] Структура

Новые драйвера после их разархивации «разбросаны» по папкам, которые содержат массу файлов, на первый взгляд, совершенно ненужных пользователю.

Для того, чтобы выбрать «нужные» файлы, требуется в распакованных файлах найти один с расширением *.inf. Именно он содержит (в секции [SourceDisksFiles]) перечень необходимых файлов, именно по этому перечню и требуется скопировать список файлов в предварительно созданную пользователем папку. Примечание: если среди распакованных файлов нет инф-файла, то автоматическое создание пакета драйверов невозможно. Настоятельно не рекомендуется (!) удалять файлы с расширением *.САТ – сведения о цифровой подписи.

Структуру нового архива драйверов можно отобразить схематически, обратив внимания на особенности ее создания.

Создается папка D (сокр. от «Drivers») и драйверы помещаются в любую подпапку внутри директор D. Имя подпапки (поддиректории) может быть любым, но рекомендуется использовать максимально короткие имена. Стоит избегать длинных путей к файлам, это может привести к ошибкам и помешать установке.

При создании структуры папок пакета драйверов следует придерживаться определенных общепринятых правил именования. Обязательно должны использоваться только английские названия папок.

Название папки | Английское название | Пояснение
A | Additions | Дополнения
B | Broadband | Широкополосные сетевые устройства(*DSL-модемы и им подобные)
C | Chipset | Наборы системной логики(чипсеты)
CPU | Central processor unit | Центральный процессор(необходим для AMD K8)
D | Dial-Up | Модемы
G | Graphics | Видеоадаптеры(Графические карты)
L | LAN | Сетевые адаптеры
M | Mass Storage | Контроллеры жестких дисков
P | Printers | Принтеры
S | Sound | Звуковые адаптеры
VMWare | VMWare | Драйверы для виртуальной машины VMWare
W | WLAN | Беспроводные адаптеры
U | USB | USB-устройства (флешки, фотокамеры)
Y | Misc | Разное (Все что не попало в другие разделы)
Y | Monitor | Мониторы
Z | Hid | Устройства ввода (Интелектуальные мыши, клавиатуры тачпады и т.п.)

В созданных папках драйверы разделяются по производителям, тем самым, образуя подпапки. Названия производителей также рекомендуется максимально сокращать. Например: «NVidia» – N, «ATi» – A и т. д. Внутри папки с именем производителя разные драйверы располагаются в папках 1-9, при необходимости число папок может быть увеличено. После создания необходимой структуры папок поместите ваши драйверы в соответствующие подпапки (примечание: распакованные файлы, INF-файлы, но не архивы или программы установки).

[править] Где скачать

Для «прицельного скачивания необходимых драйверов рекомендуется начать работу с сайта производителя оборудования (см. раздел "Полезная информация"), для которого и ищется новый драйвер. В списке установленного оборудования – по ссылке на сайт производителя можно найти и скачать требуемый драйвер. Также эту работу можно доверить программе, выбрав режим «Поиск драйвера в Интернет».

Новый драйвер можно добавить в собственную базу (пакет) драйверов, чтобы впоследствии все необходимые действия программа выполняла автоматически, независимо от того, на какой ПК она будет установлена. То есть, пополняя (выборочно) свою базу драйверов, пользователь сможет автоматизировать процесс обновления драйверов на других компьютерах.

Примечание: служба техподдержки и форум http://drp.su/forum/ помогут решить проблему как поиска, так и установки необходимых драйверов.

[править] Процесс создания индексов

Индексирование позволит ускорить поиск драйверов, то есть напрямую влияет на производительность системы.

Процесс создания пакетов драйверов (пользовательских).

После создания структуры папок с новыми драйверами требуется заархивировать созданную папку (в примере – это папка D) в соответствии с требованиями программы к архиву.

  • Имя архива: DP_НазваниеПакетаДрайверов_ x86-32_ВерсияПакетаДрайверов.7z

Требования: имя архива не должно содержать пробелов. Например, название пакета драйверов версии 9.06 для контроллеров жестких дисков должно быть таким: DP_MassStorage_x86-32_906.7z.

  • Формат архива: 7z.
  • Уровень сжатия: Ultra (для обеспечения максимальной компрессии, при желании Вы можете указать меньший уровень сжатия).
  • Метод сжатия: LZMA (значение установлено по умолчанию, изменять его не рекомендуется).
  • Размер словаря: 32 Mb

Значение установлено по умолчанию. Можно увеличить или уменьшить значение этого параметра. Увеличение данного параметра позволят достичь большей компрессии, но требует больше времени для создания архива.

  • Размер слова: 256.

Результат – созданный архив. Этот архив добавляется в папку программы DriverPack Solution 10, в поддиректорию DRP (драйверпаки). Новый (пользовательский) архив драйверов создан, добавлен и готов к работе (к использованию его программой DriverPack Solution 10).

[править] Структура индексных файлов

Индексные файлы хранятся в *.txt - формате, и находятся в папке "dev_db".
Структуру индексных файлов целесообразно рассмотреть на примере двух драйверов.

Содержимое индексного файла для 1-го:
PCI\VEN_8086&DEV_24D5&SUBSYS_680316F3 Audio_w7x64_912.2\ Audio_w7x64_912.2\3\1\Alcwdm18.inf Realtek.NTamd64 06/19/2009,6.0.1.6305 Realtek AC'97 Audio

Содержимое индексного файла для 2-го:
HDAUDIO\FUNC_01&VEN_10DE&DEV_8067 Audio_w7x64_912.2\ Audio_w7x64_912.2\11\1\nvhda.inf VIDIA.NTamd64 11/11/2009,1.00.00.63 NVIDIA High Definition Audio

Более развернуто объяснение структуры приведено в таблице.

Элементы структуры | Драйвер 1 | Драйвер 2
Device ID (идентификатор устройства) | PCI\VEN_8086&DEV_24D5&SUBSYS_680316F3 | HDAUDIO\FUNC_01&VEN_10DE&DEV_8067
Путь хранения драйвера в архиве | Audio_w7x64_912.2\Audio_w7x64_912.2\3\1\ | Audio_w7x64_912.2\Audio_w7x64_912.2\11\1\
Название inf-файла | Alcwdm18.inf | nvhda.inf
Тип | Realtek.NTamd64 | NVIDIA.NTamd64
Дата выпуска и версия | 06/19/2009,6.0.1.6305 | 11/11/2009,1.00.00.63
Название устройства | Realtek AC'97 Audio | NVIDIA High Definition Audio

Таким образом, наличие проиндексированных архивов драйверов значительно упрощает их поиск, следовательно, производительность программы растет.

[править] Обновления

[править] Обновления программы

Новые версии программы содержат новые пакеты актуальных драйверов. Обновив программу, вы получаете не только повышение производительности работы программы DriverPack Solution, но и более эффективную работу устройств и системы в целом, за счет использования более совершенных версий драйверов. Доступность и бесплатность обновления, быстрота и простота, это причины по которым стоит воспользоваться ресурсами, предложенными на сайте http://drp.su/.

[править] Обновления драйверов

Возможно как самостоятельное обновление, так и частично «самостоятельное». Когда для выбранного пользователем устройства DriverPack Solution 10 производит поиск драйвера в Интернете, если версия найденного дравера – более новая, производится его установка.

Служба технической поддержки http://forum.drp.su/ готова оказать помощь как в поиске необходимых драйверов, так и в их корректной установке.

[править] Сервис DevID.drp.su

DevID.drp.su – специализированный Интернет-сервис для поиска новых (актуальных) версий драйверов. Им можно пользоваться как обособленно, так и в интегрированными в его работу функциями DriverPack Solution 10.

[править] Основные функции

Удобство и простота в использовании удачно сочетаются с высокой производительностью работы. Если пользователь желает самостоятельно найти требуемый ему драйвер, то, руководствуясь подсказками, он осуществит свое намерение в несколько кликов. Пошаговое руководство позволит провести все это быстро и безошибочно.

[править] Интеграция с DriverPack Solution

Основная задача интеграции – экономия времени пользователя, исключение возможных неточностей и ошибок при выборе устройства, для которого осуществляется поиск драйвера. Если у пользователя уже установлена DriverPack Solution, то даже эти несложные действия совершать не требуется. Достаточно кликнуть на пиктограмму «Поиск в Интернете» в интерфейсе самой программы, отметив при этом устройство, для которого требуется найти драйвер. Программа сама подставит в строку поиска идентификатор устройства, и пользователь уже увидит результаты: перечень рекомендуемых драйверов.

[править] Температура процессора

Перегрев процессора.Все знают, что это может просто вывести его из строя. Также снизить производительность работы процессора примерно в 2,7 раз.Оптимальная температура для процессоров – в среднем до 50 градусов, максимальная – зависит от конфигурации, кулеров, производителя.

Индикация состояния (температуры) процессора в DriverPack Solution 10 позволяет, прежде всего, оптимально распределить нагрузку (количество работающих приложений) для сохранения высокой производительности работы компьютера.

[править] Устранение проблем

Ошибки, проблемы, которые возникают при работе программы DriverPack Solution 10, условно можно разделить на 3 направления:

  • Ошибки самой программы
  • Ошибки (неверные действия) пользователя
  • Ошибки, возникающие в результате сбоев в работе системы, независимо от DriverPack Solution 10, или действий пользователя

10-я генерация программы принесла свои результаты – минимизацию собственно программных ошибок.

Удобный интерфейс, простота в использовании сводит к минимуму уровель пользовательских ошибок.

А вот системные (и прочие) ошибки могут негативно повлиять на работу программы и системы в целом. Для их устранения и недопущения аналогичных сбоев в будущем, рекомендовано обращение в службу технической поддержки. Там пользователю помогут как устранить саму ошибку, так и принять меры для ее недопущения в будущем.

Разумеется, полученная информация об ошибке будет использована при разработке новых версий программы.

[править] Создание отчёта об ошибках

При обращении в службу технической поддержки следует немного систематизировать сообщение об ошибке. Это позволит быстро классифицировать проблему, быстро ее решить.

Примечание: при попытке систематизации проблемы, создания отчета об ошибках, в более чем 20% случаях, проблема решалась самим пользователем, который уже сам видел, где собственно ошибка и мог ее устранить самостоятельно.

Интерфейс (поддержка) позволяет, быстро заполнив необходимые «строчки», получить гарантированное разрешение возникшего у пользователя вопроса.

Последовательность действий.

Выбрать тип проблемы.

Из списка выбрать тип проблемы, максимально приближенно к уже описанным в списке. Классификация проблемы по типу позволит быстро задействовать для ее решения профильного специалиста.

Написать сообщение.

Изложение сути проблемы, описание, указание действий, в результате которых возникает сама ошибка.

Присоединить к сообщению лог-файл.

Намного быстрее, чем самостоятельно описывать проблему, присоединить к сообщению соответствующий лог-файл. Например, при возникновении проблемы, связанной с установкой драйвера можно присоединить к сообщению об ошибках лог-файл, а также файл, содержащий сведения о системе.

Лог файл (LogFile.txt) - это текстовый файл, своего рода журнал, куда программа записывает результаты своей работы. Данный файл расположен в папке с программой. Для получения файла содержащего сведения о системе нажмите на кнопку «Информация о системе». В открывшемся окне, в меню «Файл» выберите пункт «Экспорт...», укажите название сохраняемого файла (оно может быть любым, к примеру «Сведения о системе») и место для сохранения. После чего нажмите на кнопку «Сохранить». Отправленный файл будет изучен специалистами, что значительно повышает как скорость, так и вероятность успешного устранения ошибки.

Для еще более эффективной совместной работы по устранению ошибок рекомендуется в отчете указывать конфигурацию DriverPack Solution, а также информацию о версии Windows.

[править] Отправка отчёта разработчикам

Отчет можно отправить как по адресу info@drp.su, так и по контактам, указанным на форуме http://forum.drp.su/.

Более того, посетив форум, можно увидеть готовое решение аналогичой проблемы, которое «выложено» в виде рекомендаций в соответствующей теме.

[править] Использование стороннего кода

[править] Модуль 7za

7-Zip - архиватор файлов с высокой степенью сжатия.

Основные возможности 7-Zip

• Высокая степень сжатия благодаря новому формату 7z с компрессией LZMA

• Поддерживаемые форматы:

o Архивирование / разархивирования: 7z, ZIP, GZIP, BZIP2 и TAR

o Только разархивирование: ARJ, CAB, CHM, CPIO, DEB, DMG, HFS, ISO, LZH, LZMA, MSI, NSIS, RAR, RPM, UDF, WIM, XAR и Z.

• Для форматов ZIP и GZIP, архиватор 7-Zip предлагает сжатие которое в 2-10 % лучше чем сжатие предоставляемое архиваторами PKZip и WinZip

• Сильное шифрование в форматах 7z и ZIP

• Возможность самораспаковки для формата 7z

• Интегрирование в проводник Windows

• Мощный менеджер файлов

• Мощная версия для командной строки

• Плагин для FAR Manager

• Переведен на 74 языка

Работа с модулем 7za означает высокоэффективное использование возможностей архиватора, ускорение поиска необходимых драйверов.

[править] Модуль dpinst

Driver Package Installer (DPInst), являсь одним из компонентов DIFX позволяет производить установку пакетов драйверов для тех устройств, которые еще не были установлены в компьютере. То есть инициализационная установка. DPInst также автоматически обновляет драйверы для всех установленных устройств, которые поддерживаеются недавно установленными пакетами драйверов.

[править] Модуль devcon

DevCon — это программа с интерфейсом командной строки, которая используется в качестве альтернативы диспетчеру устройств С ее помощью можно включать, выключать, перезапускать, обновлять, удалять и опрашивать отдельные устройства или группы устройств.

Программа DevCon также предоставляет необходимые разработчику драйвера сведения, которые недоступны с помощью диспетчера устройств. Используется пользователями, которым удобнее (эффективнее) работать с командной строкой. Модуль позволяет как напрямую работать с программой и драйверами, так и использовать список идентификаторов для распространенных классов устройств, который актуален, если нет доступа к самому устройству.

[править] Модуль mshta

Модуль предназначен для работы с файлами *.HTA

HTA объединяют в себе все возможности Internet Explorer - его объектную модель, HTML, каскадные листы стилей (CSS), скрипты и события, а также специфическую функциональность HTA. HTA не является объектом для ограничений безопасности, накладываемых на Web-страницы, и выполняется также, как любой исполняемый файл. HTA-программы не могут быть «подписаны» непосредственно, однако могут быть установлены из различных инсталляционных форматов.

Если для корректной работы системы требуется использование этого модуля, то стоит отметить, что интеграция программы и модуля mshta настроены таким образом, чтобы не снижать производительность всей системы в целом.

[править] Лицензия

DriverPack Solution 10 является открытым программным обеспечением и распространяется по лицензии GNU GPL.

Владелец авторских прав Артур Кузяков.

Лицензия GPL предоставляет получателям (пользователям) следующие права:

  • свободу запуска программы, с любой целью
  • свободу изучения особенностей работы программы, её модификаций (предварительным условием для этого является доступ к исходному коду)
  • свободу распространения копий
  • свободу улучшения программы, и выпуска улучшений в публичный доступ (предварительным условием для этого является доступ к исходному коду)

Лицензионное соглашение (выборочно)

  • DriverPack Solution («ПРОГРАММНЫЙ ПРОДУКТ») является бесплатным («freeware») и распространяется на условиях «как есть» («as is»). Вы можете использовать ПРОГРАММНЫЙ ПРОДУКТ без всяких ограничений при условии информирования разработчиков об обнаруженных ошибках.
  • Эта программа распространяется в надежде, что она будет полезной, но БЕЗ ВСЯКИХ ГАРАНТИЙ, в том числе подразумеваемых гарантий ТОВАРНОГО СОСТОЯНИЯ ПРИ ПРОДАЖЕ и ГОДНОСТИ ДЛЯ ОПРЕДЕЛЁННОГО ПРИМЕНЕНИЯ. Смотрите Стандартную Общественную Лицензию GNU для получения дополнительной информации.
  • ПРОГРАММНЫЙ ПРОДУКТ защищен законами об авторском праве и международными договорами.
  • Разработчики непрерывно трудятся над улучшением ПРОГРАММНОГО ПРОДУКТА, стараясь сделать его более стабильным, удобным и производительным. Это невозможно сделать без вашей помощи.
  • Разработчики не несут никакой ответственности за повреждения аппаратного или программного обеспечения вызванные использованием ПРОГРАММНОГО ПРОДУКТА.
  • Использование ПРОГРАММНОГО ПРОДУКТА или других частей дистрибутива для коммерческих целей без согласия разработчиков запрещено.
  • Вы можете распространять и/или модифицировать её согласно условиям Стандартной Общественной Лицензии GNU, опубликованной Фондом Свободного Программного Обеспечения, версии 3 или, по Вашему желанию, любой более поздней версии.

Полный текст лицензии смотрите на <http://www.gnu.org/licenses/>.

Официальный сайт программы:
http://www.drp.su E-mail: info@drp.su

Справочная информация. Термины.

Открытое программное обеспечение

Источник: свободная энциклопедия — Википедия.

Открытое программное обеспечение (англ. open source software) — это программное обеспечение с открытым исходным кодом. Исходный код создаваемых программ открыт, то есть доступен для просмотра и изменения. Это позволяет использовать уже созданный код для создания новых версий программ, для исправления ошибок и, возможно, помочь в доработке открытой программы. «Открытая» лицензия не требует, чтобы открытое ПО предоставлялось бесплатно. Многие из наиболее успешных проектов открытого ПО, тем не менее, бесплатны. Открытое программное обеспечение имеет большие перспективы в России в связи с принятием правительством и президентом РФ решений по обеспечению национальной безопасности в сфере ИТ на основе внедрения открытого и свободного ПО в государственные и бюджетные организации.

Лицензия GNU GPL

Источник: свободная энциклопедия — Википедия

GNU General Public License — лицензия на свободное программное обеспечение, созданная в рамках проекта GNU в 1988 г. Цель GNU GPL — предоставить пользователю права копировать, модифицировать и распространять (в том числе на коммерческой основе) программы (что по умолчанию запрещено законом об авторских правах), а также гарантировать, что и пользователи всех производных программ получат вышеперечисленные права. (То есть, к примеру, запрещено на основе свободной программы под GPL создать другой проект и закрыть его, то есть не предоставлять его исходники пользователям. Таким образом, данная лицензия вовсе не позволяет делать с программами «что попало», как могут ошибочно трактовать данную лицензию плохо знакомые с ней.) Принцип «наследования» прав называется «копилефт» (транслитерация английского «copyleft») и был придуман Ричардом Столлмэном. По контрасту с GPL, лицензии собственнического ПО очень редко дают пользователю такие права и обычно, наоборот, стремятся их ограничить, например, запрещая восстановление исходного кода. Лицензируя работу на условиях GNU GPL, автор не отказывается от права считаться её автором.

[править] Разработчики

Создатели DriverPack Solution 10:

  • Артур Кузяков (ArtX) artx@drp.su - идея, разработка и управление проектом, программирование
  • Андрей (BadPointer) badpointer0@gmail.com - помощь в программирование, реализация новых функций
  • Илья Брейтбурд (QuarQ) quarq@bk.ru - сборка пакетов драйверов, активное тестирование программы
  • Андрей Мамаев mamaevat@bk.ru - продвижение и поддержка проекта
  • Станислав (stasys44) - перевод программы на другие языки
  • Андрей Андрущак (Andrew TT) andrew_bu_2010@inbox.ru - разработка справочной системы для DriverPack Solution 10
  • Андрей Павлов (Sonic) othersonic@gmail.com - разработка справочной системы для DriverPack Solution 9
  • Владимир Фомин (Artskill) artskill@yandex.ru - участие в разработке концептуальной модели программы, активное тестирование программы
  • Роман Усольцев (Wolf) ac2100@mail.ru - активное тестирование программы

В разработке программы также принимали участие:
romeo91, truvo, Комсомолец, ispolin, mozgabyte, samsobi, Dmitry_K, Lisabon, Mozgoder, nod201.

Огромное спасибо нашим активным пользователям, всем, кто принимал участие в тестировании программы, присылал информацию о найденных ошибках и предложения по усовершенствованию программы.

Отдельная благодарность: Дмитрию Окуневу (редактор журнала "Железо" - издательство "GameLand")
Илье Корнейчуку (редактор журнала "CHIP" - издательство "Бурда")
а также всем участникам форума http://forum.drp.su.

Обязательства.
Все пользователи программы обеспечиваются технической поддержкой. Мы ответим на все вопросы, выслушаем пожелания и постараемся исправить все найденные ошибки.
Последнюю версию программы и множество полезной информации вы найдете на официальном сайте программы:

www.drp.su
E-mail: info@drp.su

[править] Некоторые полезные ресурсы

Официальный сайт программы: http://www.drp.su

Форум: http://forum.drp.su/

  • Список возможных настроек;
  • Часто задаваемые вопросы и ответы по MediaWiki;
  • Рассылка уведомлений о выходе новых версий MediaWiki.
Источник — «http://help.drp.su/%D0%A1%D0%BF%D1%80%D0%B0%D0%B2%D0%BA%D0%B0_(%D0%B8%D0%BD%D1%81%D1%82%D1%80%D1%83%D0%BA%D1%86%D0%B8%D1%8F)_%D0%BF%D0%BE_DriverPack_Solution»
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться / зарегистрироваться
Навигация
  • Заглавная страница
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:54, 8 апреля 2010.
  • К этой странице обращались 14 101 раз.
  • Политика конфиденциальности
  • Описание Справка по программе DriverPack Solution
  • Отказ от ответственности